Be careful when installing the Blend Windows Phone 7 Add-In

.NET, Blend, Phone, Silverlight, Technical stuff, Windows Phone, Work
No Comments

This post was imported from my old blog and had 4 comments which are included as a screenshot at the end of this post.

There was a small issue today with the release of the Windows Phone Developer Tools CTP (April 2010 Refresh) refresh. The issue is that the Expression Blend Add-in Preview for Windows Phone (April Refresh) is not compatible with Blend 4.0.20408.0, which was the public RC (release candidate).

A few days ago, the Blend team released a fix for an issue that was sometimes causing a crash when Blend was starting up. This new release (V4.0.20421.0) was not very well announced however, and many people (including me) did not install it. After all, Blend did not crash at startup of either of my machines, so I didn’t deem necessary to install yet a new RC.

However, it is now clear that the Windows Phone 7 Add-In needs this latest-and-greatest version to work. If you have Blend 4.0.20408.0, you won’t be able to work with Windows Phone 7 in Blend.

To add to the confusion, the page where you can download V4.0.20421.0 from has an error, and the wrong version number is shown (at least at the time of writing). Do not let this confuse you. You must download this version and install it.

Hopefully this helps clarify some of the confusion…

Happy WinPhone7 coding :)

Laurent

GalaSoft Laurent Bugnion
Laurent Bugnion (GalaSoft)
Share on Facebook

This post was imported from my old blog. Original comments screenshot: 12-11-2013 9-03-38 PM

Leave a Reply